Skip to main content

Notifications

Calling Actions from Copilot Studio
Answered

List rows present in a table doesn't work if an item has a letter in it

Posted on by 189

My chatbot calls a flow for "list rows present in a table" to do an inventory search which works well as long as the part number doesn't contain any letters, but when the part number starts with a letter it throws an error (see images attached to this post for specific error). I made sure that the chatbot is passing in a "string" variable and verified that it is identifying it as a string in the flow also so why is it throwing the error if a letter is present? I thought a string variable would accept any characters regardless of type. Any help with this would be greatly appreciated.debug1.PNGdebug2.PNG

  • kgreen8790 Profile Picture
    kgreen8790 189 on at
    Re: List rows present in a table doesn't work if an item has a letter in it

    I did try double quotes but that failed also. However, after your suggestion I gave it another try with single quotes and this worked just fine. Thank you.

  • Verified answer
    Todd2 Profile Picture
    Todd2 on at
    Re: List rows present in a table doesn't work if an item has a letter in it

    Have you tried putting quotation marks around the "G25661"?  Since it is a string, this might help. 

Helpful resources

Quick Links

Welcome to the Power Platform…

We are thrilled to unveil the newly-launched Power Platform Communities!…

Getting Started…

Welcome to the Power Platform Community! We appreciate your visit…

Welcome to the new Power Platform Community!…

We are excited to announce our new Copilot Cookbook Gallery in the Community…

Leaderboard

#1
WarrenBelz Profile Picture

WarrenBelz 138,006

#2
RandyHayes Profile Picture

RandyHayes 76,308

#3
Pstork1 Profile Picture

Pstork1 63,059

Leaderboard

Featured topics