Skip to main content

Notifications

Announcements

No record found.

Calling Actions from Copilot Studio
Answered

List rows present in a table doesn't work if an item has a letter in it

Posted on by

My chatbot calls a flow for "list rows present in a table" to do an inventory search which works well as long as the part number doesn't contain any letters, but when the part number starts with a letter it throws an error (see images attached to this post for specific error). I made sure that the chatbot is passing in a "string" variable and verified that it is identifying it as a string in the flow also so why is it throwing the error if a letter is present? I thought a string variable would accept any characters regardless of type. Any help with this would be greatly appreciated.debug1.PNGdebug2.PNG

  • kgreen8790 Profile Picture
    kgreen8790 on at
    Re: List rows present in a table doesn't work if an item has a letter in it

    I did try double quotes but that failed also. However, after your suggestion I gave it another try with single quotes and this worked just fine. Thank you.

  • Verified answer
    Todd2 Profile Picture
    Todd2 on at
    Re: List rows present in a table doesn't work if an item has a letter in it

    Have you tried putting quotation marks around the "G25661"?  Since it is a string, this might help. 

Helpful resources

Quick Links

Exciting News for Copilot Studio Communi…

Get ready to experience a whole new level of engagement with the Copilot Studio…

Celebrating the May Super User of the…

LaurensM is an exceptional contributor to the Power Platform Community…

Check out the Copilot Studio Cookbook…

We are excited to announce our new Copilot Cookbook Gallery in the Community…

Featured topics