Skip to main content

Notifications

Announcements

No record found.

Power Platform Community / Forums / General / Azure OpenAI on your d...
General
Answered

Azure OpenAI on your data: deploying to a different environment than the default one or to existing chatbot

Posted on by

You can now connect Power Virtual Agents to Azure OpenAI on your data natively:

 

The deployment needs to start from the Azure OpenAI studio, after you've added "your data", and by default this creates a new chatbot in the default environment of your Power Platform tenant.

 

Here are workaround steps if you'd like to deploy to a different environment or if you need to enable this for an existing chatbot.
Note that this is subject to change, are the feature is still in preview, and the below guidance is only provided "as is".

Categories:
  • megDhuff Profile Picture
    megDhuff 4 on at
    Re: Azure OpenAI on your data: deploying to a different environment than the default one or to existing chatbot

    Here are pictures of the configuration. I am using the default settings that are provided by the OAI studio wizard.

  • citron-truc Profile Picture
    citron-truc 395 on at
    Re: Azure OpenAI on your data: deploying to a different environment than the default one or to existing chatbot

    Good morning, I hope you are doing well.
    Could you send us pictures of how you configured your generative answer ? Have a great day !

  • citron-truc Profile Picture
    citron-truc 395 on at
    Re: Azure OpenAI on your data: deploying to a different environment than the default one or to existing chatbot

    Good morning,

    I hope you are doing well. Looking at your work, it seems to be missing the querytype (when you ask a question to your genai, you first do a search on your Azure AI Search. Query type specifies how you search for your documents).

    Try to activate semantic ranking in azure ai search (this tutorial can help https://learn.microsoft.com/en-us/azure/search/semantic-how-to-enable-disable?tabs=enable-portal ) and write "semantic" in query type.

  • megDhuff Profile Picture
    megDhuff 4 on at
    Re: Azure OpenAI on your data: deploying to a different environment than the default one or to existing chatbot

    I'm having the same issue. None of my generative answers match the answers in the OpenAI studio chat playground after deployment from the Openai Studio directly to the Copilot Studio. Instead, everything is treated as though there is no Knowledge Source according to the debug insights.

     

  • fayemacapagal Profile Picture
    fayemacapagal 2 on at
    Re: Azure OpenAI on your data: deploying to a different environment than the default one or to existing chatbot

    Hello, I have the same issue, my copilot is not responding answers from data source Azure OpenAI, not sure if i miss something in configuration like the metadata etc.

     In Azure AI studio, I did not setup the mapping but only keyword search, but it is returning results from the chat playground. I did all the setup deploying from AI studio to copilot studio already.  

     

    fayemacapagal_2-1715332352598.png

     

     

    fayemacapagal_0-1715331580705.png

     

    fayemacapagal_1-1715331724784.png

     

     

  • apcsaba1 Profile Picture
    apcsaba1 2 on at
    Re: Azure OpenAI on your data: deploying to a different environment than the default one or to existing chatbot

    To integrate AzureOpenAI with an existing Copilot, If I know my AzureOpenAI API Key, can I start from Power Platform Environment (not the default environment), the create a new Azure OpenAI Connection (which is currently in preview)? 

    apcsaba1_0-1715095156567.png

    What should I use for the Azure OpenAI resource name?

     

    Why there is no documentation that explain this route which is naturally what a Power Platform developer takes to create a Power Platform Solution?

    Why should I always start from OpenAI to deploy a copilot Chatbot (connected to the OpenAI service)?

  • HenryJammes Profile Picture
    HenryJammes on at
    Re: Azure OpenAI on your data: deploying to a different environment than the default one or to existing chatbot

    Is it possible that a DLP policy is blocking the creation of the connector? 
    See if you can get more details on an exception in the network traces. 

    The wizard experience works well if the Copilot Studio environment and the Azure OpenAI service are on the same tenant (though technically not required as it’s setting up the connection using an API key) 

  • RS-Engrsketch Profile Picture
    RS-Engrsketch 5 on at
    Re: Azure OpenAI on your data: deploying to a different environment than the default one or to existing chatbot

    Hi @HenryJammes ,

    I followed your guide and deployed the bot successfully but the connection was not created. Is this feature only available in the US regions? my resources are in west europe region.

  • Ragavan Rajan Profile Picture
    Ragavan Rajan 51 on at
    Re: Azure OpenAI on your data: deploying to a different environment than the default one or to existing chatbot

    Hi @HenryJammes 

     

    In other environments > Adding an Azure Open AI connection is hard. Not sure there is a way.  Also, existing connection details can't be seen. 

     

    Any help pls 

  • Deon1 Profile Picture
    Deon1 9 on at
    Re: Azure OpenAI on your data: deploying to a different environment than the default one or to existing chatbot

    When I open the connections in Power Platform, I get the exact same issue where it doesnt load. Can I ask if you ever resolved this?

Helpful resources

Quick Links

Exciting News for Copilot Studio Communi…

Get ready to experience a whole new level of engagement with the Copilot Studio…

Celebrating the May Super User of the…

LaurensM is an exceptional contributor to the Power Platform Community…

Check out the Copilot Studio Cookbook…

We are excited to announce our new Copilot Cookbook Gallery in the Community…

Leaderboard

#1
renatoromao Profile Picture

renatoromao 6,459

#2
Pstork1 Profile Picture

Pstork1 1,954

#3
Expiscornovus Profile Picture

Expiscornovus 1,648