Skip to main content

Notifications

Topic Creation & Management
Unanswered

Object reference error for all topics - when editing

Posted on by 8

For the last few days every attempted change of a Topic results in an "Object reference not set to an instance of an object" 

k0lend0i_1-1713283079048.png

 

This error appears for any type of change to a topics (additions, removals, or changes to strings)  - to the best of my knowledge the studio configuration has not changed in any way relevant to Topics. 

  • Umianta Profile Picture
    Umianta 262 on at
    Re: Object reference error for all topics - when editing

    Thank you, @k0lend0i , for informing me. I'm pleased to hear that the problem has been sorted out for you.

     

    If my response has addressed your query, kindly mark your post as Solved.

    If you found my response helpful or it provided you with a direction to proceed, please give it a Thumbs Up. Your Kudos are appreciated. You can accept multiple posts as solutions.

    If you're still encountering any issues or challenges, please don't hesitate to inform me so I can assist you further. I'm here to help.

    Cheers ,

    Umesh Khandelwal

  • k0lend0i Profile Picture
    k0lend0i 8 on at
    Re: Object reference error for all topics - when editing

    Hi @Umianta , thank you for your help on this issue. Since the last I posted the problem has gone away (without any config change) so I'm back to believing it was a platform issue. 

  • Umianta Profile Picture
    Umianta 262 on at
    Re: Object reference error for all topics - when editing

    Could you provide me with the topic YAML file or Chatbot solution so that I can troubleshoot the issue for you?

  • k0lend0i Profile Picture
    k0lend0i 8 on at
    Re: Object reference error for all topics - when editing

    That did not resolve the issue

     

  • Umianta Profile Picture
    Umianta 262 on at
    Re: Object reference error for all topics - when editing

    Attempt to turn off and then turn on Topic again to see if it resolves the issue. 

     

     

  • k0lend0i Profile Picture
    k0lend0i 8 on at
    Re: Object reference error for all topics - when editing

    Its not limited to a particular topic - it happens for all of the topics i've tested (approx. 10)

  • Umianta Profile Picture
    Umianta 262 on at
    Re: Object reference error for all topics - when editing

    If you're encountering this error exclusively with this particular topic, it's unlikely to be an issue with the Studio configuration. There may be something a miss with the topic itself. Could you provide the YAML code for this topic? I'd be glad to assist with debugging and pinpointing the problem.

Helpful resources

Quick Links

Exciting News for Copilot Studio Communi…

Get ready to experience a whole new level of engagement with the Copilot Studio…

Celebrating the May Super User of the…

LaurensM is an exceptional contributor to the Power Platform Community…

Check out the Copilot Studio Cookbook…

We are excited to announce our new Copilot Cookbook Gallery in the Community…

Leaderboard

#1
renatoromao Profile Picture

renatoromao 6,459

#2
Pstork1 Profile Picture

Pstork1 1,954

#3
Expiscornovus Profile Picture

Expiscornovus 1,667

Featured topics