Skip to main content

Notifications

Power Platform Community / Forums / General / Access settings based ...
General
Answered

Access settings based on authentication configuration are disabled

Posted on by

Screen Shot 2020-10-14 at 2.29.16 PM.png

 

As per reference here

 

I wanted to set up authentication for PVA bot and select an option called 'Only for teams.' However, when I clicked on Access option on the left the window that allows 'Require users to sigh-in' is disabled for me.

Any obvious reason?

  • Verified answer
    Jcook Profile Picture
    Jcook 740 on at
    Re: Access settings based on authentication configuration are disabled

    Hi @Anonymous 

     

    In order to use the Access options, you have to select Manual in the authentication page:

    Manual (for any channel including Teams).

    • If your authentication setting is configured to Manual, and the service provider is either Azure Active Directory or Azure Active Directory V2, you can toggle the Require users to sign in option and change the access settings for the bot.
    • If your authentication provider is set as Generic OAuth 2, you can toggle the Require users to sign in option, but you cannot control which users can access the bot. That option is only available when using Azure AD authentication.

     

    You cannot change Access options when using:

    Only for Teams

    No authentication

  • Re: Access settings based on authentication configuration are disabled

    Screen Shot 2020-10-14 at 3.23.10 PM.png

  • Jcook Profile Picture
    Jcook 740 on at
    Re: Access settings based on authentication configuration are disabled

    Hi @Anonymous 

     

    Could you share a screenshot of your Authentication page from the Security Tab

  • Re: Access settings based on authentication configuration are disabled

    Yes, but this not teams only bot and I want to be able to see following options

     

    Screen Shot 2020-10-14 at 3.00.37 PM.png

  • Jcook Profile Picture
    Jcook 740 on at
    Re: Access settings based on authentication configuration are disabled

    Hello @Anonymous 

     

    The link to the documentation says:

    Only for Teams. The bot will only work on the Teams channel. This means the user will always be signed in, and therefore the Require users to sign in option in the Access setting will be enabled and can't be changed.

Helpful resources

Quick Links

Exciting News for Copilot Studio Communi…

Get ready to experience a whole new level of engagement with the Copilot Studio…

Celebrating the May Super User of the…

LaurensM is an exceptional contributor to the Power Platform Community…

Check out the Copilot Studio Cookbook…

We are excited to announce our new Copilot Cookbook Gallery in the Community…

Leaderboard

#1
renatoromao Profile Picture

renatoromao 6,459

#2
Pstork1 Profile Picture

Pstork1 1,990

#3
Expiscornovus Profile Picture

Expiscornovus 1,700

Leaderboard