Skip to main content

Notifications

Power Platform Community / Forums / General / SharePoint Data Access...
General
Unanswered

SharePoint Data Access - Seeking Guidance and Possible Call for Help

Posted on by 10

Hi everyone,

I'm experiencing issues with accessing SharePoint data through our system. While it works some days, on others, the same queries yield no useful results. This inconsistency is challenging, and I'm wondering if it's a common problem or something specific to my setup. I've followed standard access procedures but still face limitations on what can be answered effectively.

  1. Register an application on the Azure portal (https://portal.azure.com/).

    • Copy the Application (client) ID and store it in notepad.
  2. Set up Authentication:

    • In the Azure portal, under the registered application, navigate to "Authentication" and add a platform, selecting "Web".
    • Provide the URL for redirecting. This involves going back to Copilot Studio, navigating to Settings -> Security -> Authorization, selecting Manual for Custom website, and copying the Redirect URL.
    • Use this URL in Azure under Redirect URLs and select the required options. You may need to add additional URLs as necessary.
  3. Generate a Client Secret:

    • In the Azure portal, under your application, go to "Certificates & secrets" and create a new client secret.
    • Copy the value of the client secret and store it in notepad.
    • Fill in the client ID and client secret back in Copilot Studio.
  4. Configure API Permissions in the Azure Portal:

    • Grant admin consent.
    • Add permissions for Microsoft Graph, specifically Delegated permissions. Choose "openai profile," "Sites.Read.All," and "Files.Read.All".
  5. Update Copilot Studio with Scopes:

    • Back in Copilot Studio, add the permissions to the scope, including one for the site and one for files.

Could anyone who has navigated similar issues share their insights or offer guidance? Additionally, I would greatly appreciate the opportunity for a short call to discuss potential solutions. Please let me know if anyone is available for this.

Thanks in advance for your help!

Categories:
  • adilei Profile Picture
    adilei on at
    Re: SharePoint Data Access - Seeking Guidance and Possible Call for Help

    It is actually possible as responses from Gen Answers vary, which may result in only some variations of the response getting moderated. 

     

    I would encourage you to connect your copilot to App Insights and see if specific queries are moderated.

  • Angela23 Profile Picture
    Angela23 10 on at
    Re: SharePoint Data Access - Seeking Guidance and Possible Call for Help

    hmm I dont think so since its just a question from HR, and why could it be answered yesterday but not today. it really doesnt make sense.

  • adilei Profile Picture
    adilei on at
    Re: SharePoint Data Access - Seeking Guidance and Possible Call for Help

    Is it possible queries are being blocked by content moderation?

     

    https://learn.microsoft.com/en-us/microsoft-copilot-studio/generative-answers-sharepoint-no-response#content-blocked-by-content-moderation

  • Angela23 Profile Picture
    Angela23 10 on at
    Re: SharePoint Data Access - Seeking Guidance and Possible Call for Help

    And today its back to not working mode again 😞

  • Angela23 Profile Picture
    Angela23 10 on at
    Re: SharePoint Data Access - Seeking Guidance and Possible Call for Help

    My solution has started to answer again since the new release came to Euarope yesterday and I enabled the dynamic channing and it helped. It is still not answering all I ask but getting much better than before

  • Kabilesh Profile Picture
    Kabilesh 8 on at
    Re: SharePoint Data Access - Seeking Guidance and Possible Call for Help

    Seems strange, right? I didn't change anything ,not the URL in the Gen Answers node or the query itself. But after uploading new files, responses stopped.

  • adilei Profile Picture
    adilei on at
    Re: SharePoint Data Access - Seeking Guidance and Possible Call for Help

    Hmmm..this seems puzzling. You change nothing, not the URL that the Gen Answers node is pointing to, nor the query itself, and you stop getting responses simply after uploading new files?

  • Kabilesh Profile Picture
    Kabilesh 8 on at
    Re: SharePoint Data Access - Seeking Guidance and Possible Call for Help

    Hi @adilei ,

     

    Thanks for your reply. After uploading new documents, I'm not getting responses for either old or new documents.

  • adilei Profile Picture
    adilei on at
    Re: SharePoint Data Access - Seeking Guidance and Possible Call for Help

    Thanks. So just to be clear - you are still getting responses for your old documents? 

     

    It's only questions that expect content from the newly updated documents that do not get a response?

  • Kabilesh Profile Picture
    Kabilesh 8 on at
    Re: SharePoint Data Access - Seeking Guidance and Possible Call for Help

    Hi @adilei ,

     

    I'm using SharePoint as the data source, following the same approach as Angela. Here are the steps 

     

    1. Register an application on the Azure portal (https://portal.azure.com/).
    2. Copy the Application (client) ID and store it in Notepad.
    3. Set up Authentication:
    - In the Azure portal, under the registered application, navigate to "Authentication" and add a platform, selecting "Web".
    - Provide the URL for redirecting. This involves going back to Copilot Studio, navigating to Settings -> Security -> Authorization, selecting Manual for Custom website, and copying the Redirect URL.
    - Use this URL in Azure under Redirect URLs and select the required options. You may need to add additional URLs as necessary.
    4. Generate a Client Secret:
    - In the Azure portal, under your application, go to "Certificates & secrets" and create a new client secret.
    - Copy the value of the client secret and store it in Notepad.
    5. Fill in the client ID and client secret back in Copilot Studio.
    6. Configure API Permissions in the Azure Portal:
    - Grant admin consent.
    - Add permissions for Microsoft Graph, specifically Delegated permissions. Choose "openai profile," "Sites.Read.All," and "Files.Read.All".
    7. Update Copilot Studio with Scopes:
    - Back in Copilot Studio, add the permissions to the scope, including one for the site and one for files.

     

    It was working fine in the test canvas as well as in the demo site.

     

    Afert that, I uploaded new documents to the site and tried it around, but it didn't revert back with the response. It gives me the fallback all the times.

Helpful resources

Quick Links

Exciting News for Copilot Studio Communi…

Get ready to experience a whole new level of engagement with the Copilot Studio…

Celebrating the May Super User of the…

LaurensM is an exceptional contributor to the Power Platform Community…

Check out the Copilot Studio Cookbook…

We are excited to announce our new Copilot Cookbook Gallery in the Community…

Leaderboard

#1
renatoromao Profile Picture

renatoromao 6,459

#2
Pstork1 Profile Picture

Pstork1 1,954

#3
Expiscornovus Profile Picture

Expiscornovus 1,667