Skip to main content

Notifications

Building Copilot Studio Chatbots in Microsoft T...
Unanswered

Not resolvable unknown error

Posted on by

Hello community, 

I was trying to build a MCQ in the chatbot which has around 5 options. I want to create a new branch if the selected option matches one of the value, and for the other options I want to simply navigate to the next question. The flow instruction is very simple, yet the bot throws some unknown error (Incompatible type comparison) every time I arrive at this question. Kindly request the community to provide me with some work arounds to resolve this issue.

 

A side question: I am not able to save the topics that I am working with. Sometimes it gets saved but it is not reflected in the topics window. A blank screen appears when I try to open the respective topic.

 

I have attached the screenshots of the error for reference

Thank you all.

Categories:
  • helloworld111 Profile Picture
    helloworld111 4 on at
    Re: Not resolvable unknown error

    Hi,

    The idea here was to trigger bot by mentioning botname in teams channel via post request by incoming webhook however it mistakes bot to be an unknown user even though it has been configured in channel and works right when manually mentioned. Rest group users are getting mentioned and there's no issue with that. However, the real issue is with the bot as @botname should trigger the bot but it isn't working as expected. I have tried using power automate inorder to trigger bot but organisation permissions don't allow me to workaround that way. Is there any other way out?

  • HenryJammes Profile Picture
    HenryJammes on at
    Re: Not resolvable unknown error

    I'm really not sure about that scenario. Can you not impersonate a real user when you tag the bot with your webhook?

  • helloworld111 Profile Picture
    helloworld111 4 on at
    Re: Not resolvable unknown error

    Hello,

    I planned on integrating incoming webhook to post a message to teams channel for the bot to trigger and take required actions

    However, when I manually @mentionbotname the bot does it's job but if I do the same with incoming webhook it recognises bot as unknown user and fails to my detect it as botname.

    @HenryJammes I have attached relevant images below wherein if I manually mention bot it is doing the job but if I post the same with incoming webhook it is failing to perform the action. Please help me with finding the solution.Thankyou.

  • HenryJammes Profile Picture
    HenryJammes on at
    Re: Not resolvable unknown error

    Hi @Anonymous,

     

    Can you share more details / screenshots? 

    Perhaps the full YAML from the topic that you can get from the code editor?

     

    I don't repro the behavior you're seeing.

     

    HenryJammes_0-1687557204902.png

     

Helpful resources

Quick Links

Exciting News for Copilot Studio Communi…

Get ready to experience a whole new level of engagement with the Copilot Studio…

Celebrating the May Super User of the…

LaurensM is an exceptional contributor to the Power Platform Community…

Check out the Copilot Studio Cookbook…

We are excited to announce our new Copilot Cookbook Gallery in the Community…

Leaderboard

#1
WarrenBelz Profile Picture

WarrenBelz 137,998

#2
RandyHayes Profile Picture

RandyHayes 76,308

#3
Pstork1 Profile Picture

Pstork1 63,059

Leaderboard

Featured topics