Skip to main content

Notifications

Building Copilot Studio Chatbots in Microsoft T...
Answered

Can't save modified details ChatBot

Posted on by

hello everyone,

My problem is fast, I have created and published a ChatBot, everything works fine. But I'm trying to "edit details" like icon, short and long description, when I click save, Teams keep "saving your changes..."

I'm wondering if admin permissions are needed or if the functionality is broken.

 

 

 

Categories:
  • micchow Profile Picture
    micchow on at
    Re: Can't save modified details ChatBot

    Thank you @SDJM  for the update. We are working on a fix for the default developer name string being longer than 32 chars.

  • Verified answer
    Re: Can't save modified details ChatBot

    Hello everyone, we found the problem. So I'm posting it hoping it might help someone.

     

    We checked the network error using the google chrome developer tool. And we found that the DeveloperName field, its default value ("Con tecnología de Power Virtual Agents") in Spanish is greater than 32 characters. So we changed that field to a value with less than 32 characters and everything worked fine.

     

    SDJM_0-1651694443229.png

     

  • Re: Can't save modified details ChatBot

    @micchow Yeah, I'm stuck on the 'saving your settings' spinner. I tried the same process in the Teams browser and got 2 errors in the console.

     

    main.927ca81e.js:2 PUT https://powerva.microsoft.com/api/botmanagement/v1/channels/msteams/app/save?isConsentProvidedToChangeACPToAny=false 400

    ...

    ------------------------------------------------------------------------------------------------------------------------------

    main.927ca81e.js:2 Uncaught (in promise) Error: An unexpected server error occurred.
    at Mt (main.927ca81e.js:2:3309044)
    at main.927ca81e.js:2:3180023

    ...

     

    Do you have any idea what's going on?

    Thanks.

  • micchow Profile Picture
    micchow on at
    Re: Can't save modified details ChatBot

    @SDJM , I am unable to reproduce the issue, the information is being saved correctly. To answer your question, you should be able to save the detail changes as the bot owner without needing to be an admin. Could you clarify the issue a bit more? Are you stuck on the spinner 'saving your settings'?

     

    If the issue persists, please DM me with your tenant ID and bot ID for us to open a ticket on investigation.

  • Expiscornovus Profile Picture
    Expiscornovus 1,708 on at
    Re: Can't save modified details ChatBot

    Hi @SDJM,

     

    Have you tried the same editing experience from the browser instead of the Teams client?

     

    1. Go to http://teams.microsoft.com/ in a browser

    2. Open the Power Virtual Agents app

    3. Try editing your bot details from there

     

    Benefit of this test is also that you could open your developer toolbar on the Network monitor tab and see if maybe one of the requests is failing.

     

    Alternatively, contact Microsoft Support about this. They might be able to help you out with troubleshooting:

    https://powervirtualagents.microsoft.com/en-us/support/

     

Helpful resources

Quick Links

Exciting News for Copilot Studio Communi…

Get ready to experience a whole new level of engagement with the Copilot Studio…

Celebrating the May Super User of the…

LaurensM is an exceptional contributor to the Power Platform Community…

Check out the Copilot Studio Cookbook…

We are excited to announce our new Copilot Cookbook Gallery in the Community…

Leaderboard

#1
renatoromao Profile Picture

renatoromao 6,459

#2
Pstork1 Profile Picture

Pstork1 1,997

#3
Expiscornovus Profile Picture

Expiscornovus 1,708

Leaderboard

Featured topics