Skip to main content

Notifications

Publish & Channel Management
Unanswered

Could not complete the operation because of an invalid workflow

Posted on by 106

Morning, 

I've raised a support ticket but wondered if I'm missing the obvious. When I'm trying to create new topics, upon saving it believes someone else is in the topic making changed and asks me to discard or save a copy. 
It then duplicates the topics, usually quiet a few times. 
When publishing, it does not recognise any of the new topics I've created the last day or so. I've tried turning topics on and off to republish but I get the following message:
"Could not complete the operation because of an invalid workflow 

Diagnostic Trace Id: "

  • Matthew5 Profile Picture
    Matthew5 106 on at
    Re: Could not complete the operation because of an invalid workflow

    It's fixed! For some reason it was the new pro-active message users automated flow I introduced. Deleting that flow has meant I can now edit/publish/create new topics. No idea why it was stopping it, I'll see if Microsoft support can suss it out. 

  • Matthew5 Profile Picture
    Matthew5 106 on at
    Re: Could not complete the operation because of an invalid workflow

    Will do! 

  • renatoromao Profile Picture
    renatoromao 6,762 on at
    Re: Could not complete the operation because of an invalid workflow

    @Matthew5 ,

     

    Oh no 😞

    When you have any updates from Microsoft, let us know. Will be very useful.

  • Matthew5 Profile Picture
    Matthew5 106 on at
    Re: Could not complete the operation because of an invalid workflow

    Thanks Renato, 
    That's the thing. I'm not actually working on topic with anyone else, it's just me working/creating them but when saving the topic, it's acting like someone else has been in and made changes as it presents the discard or save copy message. 
    Thanks

  • renatoromao Profile Picture
    renatoromao 6,762 on at
    Re: Could not complete the operation because of an invalid workflow

    Hi @Matthew5 ,

     

    It's not recommended to work on the same topic with someone else yet.

     

    I think that the structure is losing something when you are doing it, also I guess that the Microsoft support team will help you by looking at the logs and so on.

    Maybe it is an issue behind the scenes which they can understand better.

Helpful resources

Quick Links

Exciting News for Copilot Studio Communi…

Get ready to experience a whole new level of engagement with the Copilot Studio…

Celebrating the May Super User of the…

LaurensM is an exceptional contributor to the Power Platform Community…

Check out the Copilot Studio Cookbook…

We are excited to announce our new Copilot Cookbook Gallery in the Community…

Leaderboard

#1
WarrenBelz Profile Picture

WarrenBelz 137,998

#2
RandyHayes Profile Picture

RandyHayes 76,308

#3
Pstork1 Profile Picture

Pstork1 63,059

Leaderboard

Featured topics