Skip to main content

Notifications

Announcements

No record found.

Publish & Channel Management
Answered

Approval in Teams Admin Center not coming through?

Posted on by 19

I have submitted version 1.0.0 of my Power Virtual Agents Teams chatbot to "Show to everyone in my org". That went through to the Teams Admin center, but did take about 2 hours before it appeared and after that, before it would allow me to approve it.

 

There was a problems with the app's icon so I submitted a second version. After waiting three hours nothing had appeared. I tried publishing and submitting again and I am now waiting on version 1.0.3 to be approved but nothing is showing in Teams Admin Center.

 

The Show to everyone in my org panel in the PVA app shows:

 

Chatbot

Version 1.0.3

Waiting for approval

 

Chatbot

Version 1.0.0

Published by your organization

 

In the Teams Admin center I see the Chatbot is Published as version 1.0.0 but nothing the Pending approval panel on the Manage apps page says 0 Updated custom apps and opening the Chatbot app is not giving me the button to approve it. I am a Teams Administrator and my Global Admin has confirmed they see the same as myself.

 

The Pending approval panel did flash up briefly on two occasions that there was 1 custom app requiring approval, and opening the app on the Manage apps page did show the approve button, but clicking it did nothing and when I refreshed the page it disappeared, still on version 1.0.0 and no longer reporting any apps awaiting approval.

 

 

How long should it take for a Teams app approval to come through for my PVA chatbot? So far it has been about 15 hours. Is there anything I can do? 

Categories:
  • Verified answer
    AndyH3 Profile Picture
    AndyH3 19 on at
    Re: Approval in Teams Admin Center not coming through?

    Got the answer: it was 'some time'.

     

    If any help in the future, this is what happened.

     

    First publish - 2 hours to appear on Teams Admin Center and allow approval

    Second publish (first update) - 27 hours

    Third publish (second update) - 2 hours

     

    During the wait, Teams Admin center would occasionally report that the app had an update to approve. Going to the page would reveal the Publish update button but an error message appears at the top of the screen "We can't get details related to this app. Try again. If you continue to have problems, contact Microsoft customer support.". Refresh the page and the update would disappear most of the time so I guess it just was not ready. One time refreshing did remove the error message and was able to approve the chatbot app, so it is worth giving that a try.

     

Helpful resources

Quick Links

Exciting News for Copilot Studio Communi…

Get ready to experience a whole new level of engagement with the Copilot Studio…

Celebrating the May Super User of the…

LaurensM is an exceptional contributor to the Power Platform Community…

Check out the Copilot Studio Cookbook…

We are excited to announce our new Copilot Cookbook Gallery in the Community…

Leaderboard

#1
renatoromao Profile Picture

renatoromao 6,459

#2
Pstork1 Profile Picture

Pstork1 1,954

#3
Expiscornovus Profile Picture

Expiscornovus 1,648

Featured topics