Skip to main content

Notifications

Topic Creation & Management
Suggested answer

Error in HTTP Call: I apologize, but as an AI language model, I don’t have real-time access

Posted on by 16
I have developed a copilot chatbot using the copilot studio, where I am calling the HTTP action to read data from an external API. Then, I am storing the output of the API in a variable, and then I display the variable in the message node. Then, when I ask about anything from the API data source, it answers well, but if I don't add the API response result in a variable using the message node, the copilot doesn't answer as expected; it gives this answer: "I apologize, but as an AI language model, I don’t have real-time access to external data or APIs." Please help me to fix it.
 
Let us look at the below image, after the http request action node if we add the "Message" node and display the http response variable, the copilot works very well but the moment we remove the message node (which we don't want to display as it displays entire http response), the copilot doesn't answer, it just always says - "I apologize, but as an AI language model, I don’t have real-time access to external data or APIs."  I am wondering why I am getting this result as I am dealing with the variable of http response, so it should not matter whether I should display the variable in the message node or not. Please someone assist me on this, if you had similar issues. 
 
 
 
  • M365Techy Profile Picture
    M365Techy 16 on at
    Error in HTTP Call: I apologize, but as an AI language model, I don’t have real-time access
    Hi,
     
    Thanks for your reply. I have tried your steps, it didn't work. Please see answer inline:
     
    1. Turn off "Allow the AI to use its own general knowledge (preview)" option 
     
    Result: By disabling this, the standard AI message (I apologize, but as an AI language model, I don’t have real-time access to external data or APIs) stopped appearing but the Copilot didn't work.
     
    2. After http action , add end current topic node 
     
     
    Result: It just ended the current topic and didn't move on to the next node which is expected as we are ending the current topic. As a result, it didn't solve the problem, Copilot didn't work.
  • Suggested answer
    Umianta Profile Picture
    Umianta 293 on at
    Error in HTTP Call: I apologize, but as an AI language model, I don’t have real-time access
    Below options may help to resolve this issue -
     
    1. Turn off "Allow the AI to use its own general knowledge (preview)" option 
     
     
    2. After http action , add end current topic node 
     
     
    If this was helpful:
    Please mark it as a Answered 
    Give me a thumbs-up
    Connect on LinkedIn
    I consistently upload technical videos. If you're interested, please visit and subscribe to my YouTube Channel
    Always glad to help, Umesh Khandelwal!

Helpful resources

Quick Links

Welcome to the Power Platform…

We are thrilled to unveil the newly-launched Power Platform Communities!…

Getting Started…

Welcome to the Power Platform Community! We appreciate your visit…

Welcome to the new Power Platform Community!…

We are excited to announce our new Copilot Cookbook Gallery in the Community…

Leaderboard

#1
WarrenBelz Profile Picture

WarrenBelz 138,030

#2
RandyHayes Profile Picture

RandyHayes 76,308

#3
Pstork1 Profile Picture

Pstork1 63,085

Leaderboard

Featured topics