Skip to main content

Notifications

Building Copilot Studio Chatbots in Microsoft T...
Unanswered

System.User.PrincipalName not returning updated value in MS Teams

Posted on by 238

Hello All,

 

We have a copilot studio bot with Teams authentication enabled. Due to org changes our User Principal Name (UPN) and email changed across. I'm able to confirm the new UPN reflected in azure portal, Microsoft Graph API explorer and co pilot studio debug window but in teams channel it's still returning old UPN value. I have signed out from teams and logged with new UPN, cleared teams cache, used teams web it is still returning old UPN.  Suspecting cause may be from Teams application.

Please provide if you have any other suggestions?

Any way to resolve this issue?

 

Thanks.

  • avip1607 Profile Picture
    avip1607 2 on at
    Re: System.User.PrincipalName not returning updated value in MS Teams

    Can you tell me how you used Microsoft Graph with Copilot studio as I want to explore and use Microsoft Graph for statistical calculation?

     

Helpful resources

Quick Links

Exciting News for Copilot Studio Communi…

Get ready to experience a whole new level of engagement with the Copilot Studio…

Celebrating the May Super User of the…

LaurensM is an exceptional contributor to the Power Platform Community…

Check out the Copilot Studio Cookbook…

We are excited to announce our new Copilot Cookbook Gallery in the Community…

Leaderboard

#1
renatoromao Profile Picture

renatoromao 6,459

#2
Pstork1 Profile Picture

Pstork1 1,997

#3
Expiscornovus Profile Picture

Expiscornovus 1,708

Leaderboard

Featured topics