Skip to main content

Notifications

Publish & Channel Management
Answered

Setting Global variables with external data from custom website passed as query parameter is not working

Posted on by 67

Setting Global variables with external data from custom website passed as query parameter is not working.

 

For eg, from this URL name = ${user} param is not getting replaced with passed value in my chatbot created https://copilotstudio.microsoft.com/environments/{ENV_ID}/bots/{BOT_SCHEMA_NAME}/webchat?__version__=2&name=${user}

 

Kindly help me on this

  • lluc Profile Picture
    lluc 2 on at
    Re: Setting Global variables with external data from custom website passed as query parameter is not working

    Hi, same problem here, I want to parse the language choice from the website. It works but when I change the website language it does not reload to take the new language. When I open a new tab it does the job, but I would like a way to restart/reload the chat so it can be initialised again with the updated language.

  • Karishma2805998 Profile Picture
    Karishma2805998 67 on at
    Re: Setting Global variables with external data from custom website passed as query parameter is not working

    Is there a way to clear the chat like a restart from beginning?

  • Karishma2805998 Profile Picture
    Karishma2805998 67 on at
    Re: Setting Global variables with external data from custom website passed as query parameter is not working

    In new tab it is not getting reproduced

  • adilei Profile Picture
    adilei on at
    Re: Setting Global variables with external data from custom website passed as query parameter is not working

    I think that some context is saved if you just reload the same tab. Can you try and see whether this is reproduced when using a new tab?

  • Karishma2805998 Profile Picture
    Karishma2805998 67 on at
    Re: Setting Global variables with external data from custom website passed as query parameter is not working

    One problem I am facing is, user param Global variable is holding the same previous param value even when I change my website login user. Why? Please provide me solution for this

  • Karishma2805998 Profile Picture
    Karishma2805998 67 on at
    Re: Setting Global variables with external data from custom website passed as query parameter is not working

    Amazing, this is working on the first try. Doing some more testing on it

  • Verified answer
    adilei Profile Picture
    adilei on at
    Re: Setting Global variables with external data from custom website passed as query parameter is not working

    See if this helps: Re: Get external variables - Power Platform Community (microsoft.com)

Helpful resources

Quick Links

Exciting News for Copilot Studio Communi…

Get ready to experience a whole new level of engagement with the Copilot Studio…

Celebrating the May Super User of the…

LaurensM is an exceptional contributor to the Power Platform Community…

Check out the Copilot Studio Cookbook…

We are excited to announce our new Copilot Cookbook Gallery in the Community…

Leaderboard

#1
renatoromao Profile Picture

renatoromao 6,459

#2
Pstork1 Profile Picture

Pstork1 1,995

#3
Expiscornovus Profile Picture

Expiscornovus 1,708

Leaderboard

Featured topics