Skip to main content

Notifications

Topic Creation & Management
Unanswered

Topic validates fine and saves but the topic list sill shows "2 errors" preventing publishing

Posted on by

A topic validates fine in the topic checker on the canvas but when the bot is published, 2 errors are shown in the topic status with no description.

Going to the authoring canvas shows no errors.

Any suggestions?

Thanks,
Michael

  • kgreen8790 Profile Picture
    kgreen8790 189 on at
    Re: Topic validates fine and saves but the topic list sill shows "2 errors" preventing publishing

    I finally found why the errors were showing. I had to create a copy of my topic and on the copy delete one item at a time, save, and check the topics homepage until the errors disappeared to find where the issue was happening. I had a multiple choice response question where one of the answers was "Other". For some reason PVA didn't like either the number or contents of synonyms I was using for it. It wasn't the case for the other answer options as each of them had roughly the same number of synonyms so not sure what was causing it for just this one option but I took it down to a single synonym "General" and that made the errors disappear. Strange behavior from the PVA on this one. 

  • kgreen8790 Profile Picture
    kgreen8790 189 on at
    Re: Topic validates fine and saves but the topic list sill shows "2 errors" preventing publishing

    I am having the same issue. I have tested the topic and am able to get through it with no errors, when I run the topic checker inside the topic's canvas it shows no errors but on the topics home page it shows 10 errors on that same topic. Any resolution to this?

    topic canvas shows no errorstopic canvas shows no errorstopics page shows error on same topictopics page shows error on same topic

  • Lvdk Profile Picture
    Lvdk 26 on at
    Re: Topic validates fine and saves but the topic list sill shows "2 errors" preventing publishing

    Hi @mscherotter ,

     

    I'm having the same issue with my PVA. Did you manage to fix your issue?  

  • Anujk123 Profile Picture
    Anujk123 5 on at
    Re: Topic validates fine and saves but the topic list sill shows "2 errors" preventing publishing

    I am facing the same error. how do I resolve it?

  • dougmaloney Profile Picture
    dougmaloney 59 on at
    Re: Topic validates fine and saves but the topic list sill shows "2 errors" preventing publishing

    some progress with this - though not what I expected.

     

    The topic showing "2 Errors" but with no errors reported by topic check, was actually not the only topic causing problems with publishing. By gradually working through the topic removing actions where I could, I managed to remove the reported 2 errors, though it was actually not obvious why - the removed action had no inherent errors.

     

    The error caused during publishing was caused by a different topic - named "confirmedsuccess" and mentioned in the error message below. It had a loose system included node for asking for feedback - once this was connected to another node, the publish worked.

     

  • dougmaloney Profile Picture
    dougmaloney 59 on at
    Re: Topic validates fine and saves but the topic list sill shows "2 errors" preventing publishing

    Any solution to this issue ? I'm experiencing the same thing.

    2 errors show next to the topic in Topic view, but when I go into Authoring Canvas and check the topic no errors show.

    There are no errors in any of the other topics.

     

    Publishing fails with this unhelpful message:

     

    The bot content is not valid. Please fix the following errors [{"Key":"new_topic_3716d81410e6489c8cb32ea2d5be14a5_db1f76b081dc43389df9dd2df7518737_confirmedsuccess","Value":[{"NodeId":"873b869b-eaff-4dc2-91d2-674ae00cd08d","ValidationRule":11,"ViolationSeverity":0}]},{"Key":"new_topic_c01001a7541140d1920c3e1d71eb169f","Value":[{"NodeId":"5996932a-7931-41df-916d-5aac4f770f92","ValidationRule":10,"ViolationSeverity":1},{"NodeId":"5996932a-7931-41df-916d-5aac4f770f92","ValidationRule":10,"ViolationSeverity":1}]}]
    Diagnostic Trace Id: LqNmy

  • Gitika Gupta Profile Picture
    Gitika Gupta on at
    Re: Topic validates fine and saves but the topic list sill shows "2 errors" preventing publishing

    Hi @mscherotter,

    Thanks for reporting the issue. We'd like to debug this with your help. Can you share a screenshot of your Topic list and Publish where it shows the errors, and then the authoring canvas for the topic, that would be a good starting point. 

    Thanks
    Gitika

  • renatoromao Profile Picture
    renatoromao 6,762 on at
    Re: Topic validates fine and saves but the topic list sill shows "2 errors" preventing publishing

    Hi @mscherotter ,

     

    When you are publishing the bot, the error occurred showing your custom topic or just an error in topics?

    Because the problem could be inside another topic.

Helpful resources

Quick Links

Welcome to the Power Platform…

We are thrilled to unveil the newly-launched Power Platform Communities!…

Getting Started…

Welcome to the Power Platform Community! We appreciate your visit…

Welcome to the new Power Platform Community!…

We are excited to announce our new Copilot Cookbook Gallery in the Community…

Leaderboard

#1
WarrenBelz Profile Picture

WarrenBelz 138,006

#2
RandyHayes Profile Picture

RandyHayes 76,308

#3
Pstork1 Profile Picture

Pstork1 63,059

Leaderboard

Featured topics