Skip to main content

Notifications

Topic Creation & Management
Answered

Fallback topic is not being triggered after adding a help topic that uses a forward slash "/?"

Posted on by 48

I added a help topic with the following trigger phrases to train users on available commands.

Alphie_1-1632327460070.png

 

When this topic is enabled it no longer defaults to the fallback topic that sends to the QnA flow, which is the main purpose of using the bot. Is there an issue with using a forward slash "/"?

Could my bot be broken? I do receive error messages like the following often:

Alphie_2-1632327563187.png

 

Alphie_3-1632327566217.png

 

Additionally, I tend to receive inconsistent results when typing the same questions as if there is a performance limit that is stopping the return content. Could this be a licensing issue that is limiting me to certain amount of queries?

 

I feel as though there is an underlying issue causing several problems.

Bot ID: 6c13d10e-c2eb-4ec8-bb0f-e9bcd6c5a99d

  • Expiscornovus Profile Picture
    Expiscornovus 29,248 on at
    Re: Fallback topic is not being triggered after adding a help topic that uses a forward slash "/?"

    Hi @Alphie,

     

    Good to know that it is actually a wild card 😁

  • Verified answer
    Alphie Profile Picture
    Alphie 48 on at
    Re: Fallback topic is not being triggered after adding a help topic that uses a forward slash "/?"

    It turns out that the question mark in my trigger phrase "/?" is a wild card and therefore was matching all results.

  • Alphie Profile Picture
    Alphie 48 on at
    Re: Fallback topic is not being triggered after adding a help topic that uses a forward slash "/?"

    Aww, gotta love corp security policies... Switched to unlicensed admin account, enabled PIM roles, there it is. Bless you, @Expiscornovus.

  • Verified answer
    Expiscornovus Profile Picture
    Expiscornovus 29,248 on at
    Re: Fallback topic is not being triggered after adding a help topic that uses a forward slash "/?"

    Hi @Alphie,

     

    It should look something like the screenshot below. What role do you have in your tenant? One of the admin roles should be sufficient:

    Get Help + Support - Power Platform | Microsoft Docs

     

    helpandsupportppac.png

     

    Direct link to that help + support page should be this btw:

    Power Platform admin center (microsoft.com)

  • Alphie Profile Picture
    Alphie 48 on at
    Re: Fallback topic is not being triggered after adding a help topic that uses a forward slash "/?"

    Hi @Expiscornovus ,

     

    Thanks for the feedback, I will rule out my "/" trigger as the issue. There is definitely something amiss with this logic. 

    I would love to create a support ticket, however, this is the screen receive when going to the URL you provided and clicking "Create a request". Does this look normal? If so, where do I need to go to from here to create a request?

    Screenshot 2021-09-23 145352.png

  • Expiscornovus Profile Picture
    Expiscornovus 29,248 on at
    Re: Fallback topic is not being triggered after adding a help topic that uses a forward slash "/?"

    Hi @Alphie,

     

    As far as I am aware you are allowed to use those characters in the trigger phrases, I haven't seen any limitations on that in the docs.

     

    I have also been able to use the same phrases in my demo environment, so might be something unrelated which is causing your issue.

     

    slashtopicwithouterror.png

     

    Maybe you can raise a ticket with the Microsoft support team: https://powervirtualagents.microsoft.com/en-us/support 

Helpful resources

Quick Links

Exciting News for Copilot Studio Communi…

Get ready to experience a whole new level of engagement with the Copilot Studio…

Celebrating the May Super User of the…

LaurensM is an exceptional contributor to the Power Platform Community…

Check out the Copilot Studio Cookbook…

We are excited to announce our new Copilot Cookbook Gallery in the Community…

Leaderboard

#1
WarrenBelz Profile Picture

WarrenBelz 137,998

#2
RandyHayes Profile Picture

RandyHayes 76,308

#3
Pstork1 Profile Picture

Pstork1 63,059

Leaderboard

Featured topics