Skip to main content

Notifications

Building Copilot Studio Chatbots in Microsoft T...
Unanswered

PVAiaD Lab10: Problems to publish and share bot

Posted on by 6

I was working through the "Power Virtual Agent in a Day" labs. The lab 10 Exercise 5: "Publishing and sharing your chatbot" is not updated. The publish site looks completely different and I were not able to full fil this exercise.

Could you please update exercise 5 from lab 10? 

  • Re: PVAiaD Lab10: Problems to publish and share bot

    @Expiscornovus

    I have a related question. I'm not following the lab. I published a chatbot and tried the same procedure to open the chatbot in Teams, but when I clicked "open bot" instead of allowing me to "add" the bot, I just got a warning asking to ask admin for permissions.

    Do you know why it happens? I can't find any reference to this problem in the documentation. Just to be clear, I'm not trying to share the bot with the organization, I just want to open it in my account.

    Thanks in advance.

  • TheTrees123 Profile Picture
    TheTrees123 6 on at
    Re: PVAiaD Lab10: Problems to publish and share bot

    Are there any updates?

  • Expiscornovus Profile Picture
    Expiscornovus 1,700 on at
    Re: PVAiaD Lab10: Problems to publish and share bot

    Hi @TheTrees123,

     

    Thanks for double checking and clarifying. Just want to make sure we were talking about the same thing because several products use the word web app 😁

     

    I wanted to check-out that lab myself as well. So, I will go through the several tasks to see what is different.

     

    I have already checked pages 38 & 39 (of the September 2021 lab 10 guide) look pretty similar compared to the Teams web app I am using.

     

    Page 38

     

    page38.png

    Page 39

    page39.png

  • TheTrees123 Profile Picture
    TheTrees123 6 on at
    Re: PVAiaD Lab10: Problems to publish and share bot

    I did exactly what is written in lab 10.

    Exercise 1, task 1: Go to to https://teams.microsoft.com/ --> Use web app

    Exercise 1, task 2: Add Power Virtual Agents app in teams

    Exercise 5: Difference from lab 10 to "web app of Microsoft team incl. Power Virtual Agents app"
     

  • Expiscornovus Profile Picture
    Expiscornovus 1,700 on at
    Re: PVAiaD Lab10: Problems to publish and share bot

    Hi @TheTrees123,

     

    Just to clarify, with the web app I mean Power Virtual Agents web app (https://web.powerva.microsoft.com) which is slightly different from the Power Virtual Agents App in the Microsoft Teams client.

     

    When you are talking about web app, you are talking about opening Microsoft teams in your browser (web app) vs. opening Microsoft Teams in the desktop client?

     

    As far as I can tell in the pdf I have lab 10 is focused on working in Microsoft Teams and creating and publishing it in the Power Virtual Agents App in Microsoft Teams and not in the Power Virtual Agent web app (https://web.powerva.microsoft.com).

     

    Hope this helps a bit?

  • TheTrees123 Profile Picture
    TheTrees123 6 on at
    Re: PVAiaD Lab10: Problems to publish and share bot

    Hi @Expiscornovus,

    Yes, I used the latest version of the labs. Also doubled checked it again with the link you have sent. 

    I use the web app (as it is describe on lab 10, exercise 1, task 1). 

    In the web app it looks the same as in your picture. But on the lab it is different (but very similar). But then the behavior is completely different when I click on "Make the bot available to others" (in web app) / "Share the bot" (on lab 10) for example. I cannot submit it for admin approval and it is already added to Teams.

  • Expiscornovus Profile Picture
    Expiscornovus 1,700 on at
    Re: PVAiaD Lab10: Problems to publish and share bot

    Hi @TheTrees123,

     

    Just to double check. You are using the September 2021 Lab 10 Guide pdf document, correct?

     

    The latest version of the package can be downloaded here: https://aka.ms/PVAinaDayPackage 

     

    And are you publishing it from within the Power Virtual Agents in Teams app in Microsoft Teams, or in the web app?

     

    In Teams it should look something like this:

     

    excerise5.png

Helpful resources

Quick Links

Exciting News for Copilot Studio Communi…

Get ready to experience a whole new level of engagement with the Copilot Studio…

Celebrating the May Super User of the…

LaurensM is an exceptional contributor to the Power Platform Community…

Check out the Copilot Studio Cookbook…

We are excited to announce our new Copilot Cookbook Gallery in the Community…

Leaderboard

#1
renatoromao Profile Picture

renatoromao 6,459

#2
Pstork1 Profile Picture

Pstork1 1,990

#3
Expiscornovus Profile Picture

Expiscornovus 1,700

Featured topics