Skip to main content

Notifications

Announcements

No record found.

Power Platform Community / Forums / Bot Administration / Configure bot with sit...
Bot Administration
Unanswered

Configure bot with sites.selected rather than full control

Posted on by

Looking for some assistance - has anyone been successful in getting generative answers when using sites.selected for their application? We've gone ahead and added read to the specific site for the application and that appears successful. However, when we use the generative answers action, nothing is returned in the results. 

Categories:
  • cpayton Profile Picture
    cpayton 46 on at
    Re: Configure bot with sites.selected rather than full control

    What I did was use Sites.Read.All but delegated, meaning it uses the current user's permissions in SharePoint when it searches. It won't return anything outside of the site it's configured to search in the datasource settings, so that effectively limits it.

Helpful resources

Quick Links

Exciting News for Copilot Studio Communi…

Get ready to experience a whole new level of engagement with the Copilot Studio…

Celebrating the May Super User of the…

LaurensM is an exceptional contributor to the Power Platform Community…

Check out the Copilot Studio Cookbook…

We are excited to announce our new Copilot Cookbook Gallery in the Community…

Leaderboard

#1
renatoromao Profile Picture

renatoromao 6,459

#2
Pstork1 Profile Picture

Pstork1 1,954

#3
Expiscornovus Profile Picture

Expiscornovus 1,648

Featured topics