Skip to main content

Notifications

Publish & Channel Management
Answered

Bot in iFrame stuck in infinite loading loop, does not complete loading

Posted on by 15

Good day,

I am facing an issue publishing my bot using the iframe code. Have scoured the net but didn't find anything closed to this hence posting this here.

 

I have two screenshots, one is in PBI service dashboard and one is in canvas powerapp.

 

PBI service dashboard, canvas app loads ok but PVA bot doesn't finish loading

BananaMeepok_0-1614132650572.png

 

Canvas app, using iFrame PCF component it doesn't complete loading as well

BananaMeepok_1-1614132851693.png

 

I have waited for 30 minutes or more on few tests, just in case it is taking time to load but that is not the case since the canvas app loaded in seconds on the PBI dashboard. Appreciate if anyone has any idea to troubleshoot this issue I am facing. Cheers!

 

John Low

  • Verified answer
    BananaMeepok Profile Picture
    BananaMeepok 15 on at
    Re: Bot in iFrame stuck in infinite loading loop, does not complete loading

    Hi all,

     

    The solution to this is quite unexpected. I did not made any changes but when I opened my company tenant's dashboard this week, some other PVA bots used for testing with the MSFT helpdesk staff actually loaded in edge browser but my PVA bot still does not.

     

    We have also tested using chrome browser 2 weeks back during our first test and neither bots loaded but all bots managed to load today in chrome browser.

     

    Just to reiterate, my PVA bot managed to load in edge browser in a client's tenant dashboard before I even decide to start this thread.

     

    It is bizarre is all I can say, but it is what it is. Seems to be an incompatibility issue that caused this whole saga. Regardless thanks to all who have chipped in to help resolve this. Cheers! 

  • BananaMeepok Profile Picture
    BananaMeepok 15 on at
    Re: Bot in iFrame stuck in infinite loading loop, does not complete loading

    Hi all,

     

    Update on status. There is only ONE PVA bot in subject, which is deployed to my own company's tenant. I have further tested few other scenarios as follow:

    1. Tested PVA on another tenant's PBI, loads and works fine as I did not set any security requirements. Essentially anyone with my PVA's link can use it
    2. Loaded another canvas app using the custom PCF component into this canvas app, loads and works fine but the PVA remains to not complete loading
    3. Opened the PBI dashboard in my company's tenant in PBI mobile, PVA loads and works fine

    A MSFT helpdesk staff is working on this ticket with me now. I will continue to update this thread once I get any news. Thank you for your interest.

  • renatoromao Profile Picture
    renatoromao 6,459 on at
    Re: Bot in iFrame stuck in infinite loading loop, does not complete loading

    Hi @BananaMeepok ,

     

    Great!

    So, the first option follow the steps below:

     

    1- Open your bot in the PVA studio

    2- Edit anything in your bot in the trigger phrase or something like that, just to allow to generate a new version

    3- Go to the Publish left menu

    4- Click on the Publish

    5- Go to the Channels left menu

    6- Open as a Demo website

    7- Try to see if your bot is recognizing your new trigger phrase

    8- If yes, try to open your canvas app, remove the Bot and add it again

    9- If the issue persists, click on the F12 keyboard

    10- Click on the Network tab

    11- Mark the option "Disable cache" (this feature will disable the cache in your browser when you refresh the page using CTRL + F5 or F5 or the Refresh button on the browser)

    12- Refresh your page and try to talk with your bot again

  • BananaMeepok Profile Picture
    BananaMeepok 15 on at
    Re: Bot in iFrame stuck in infinite loading loop, does not complete loading

    Thanks for your suggestions Renato! For the first suggestion, how do I do this? Any suggested links or screenshots to help locate this so I can check if they are in sync?

    For your second suggestion I have done that too, will update this thread when I get their reply.

  • renatoromao Profile Picture
    renatoromao 6,459 on at
    Re: Bot in iFrame stuck in infinite loading loop, does not complete loading

    Hi @BananaMeepok ,

     

    Two options:

    1- Try to publish your bot again, maybe you are getting an issue between both channels. Also, validate if you are using the same public connection inside your App and try to identify if you are using the same browser too.

     

    2- Open a ticket to the PVA support, they can investigate and understand issues behind the scenes

    https://powervirtualagents.microsoft.com/en-us/support 

  • BananaMeepok Profile Picture
    BananaMeepok 15 on at
    Re: Bot in iFrame stuck in infinite loading loop, does not complete loading

    Yes the bot ID is correct, it loads fine in edge. Any other troubleshooting methods are welcome 😊

    BananaMeepok_1-1614217269819.png

     

  • renatoromao Profile Picture
    renatoromao 6,459 on at
    Re: Bot in iFrame stuck in infinite loading loop, does not complete loading

    Hi @BananaMeepok ,

     

    I never faced this issue yet.

    Did you get the right Bot ID?

    Because if you use the wrong Id, you will see the long loading. One tip is to open PVA Portal >> Channels >> Custom website >> get the iframe >> get the URL and try to open it in a browser to test it. If works, get the Bot ID code in the final of the URL

Helpful resources

Quick Links

Exciting News for Copilot Studio Communi…

Get ready to experience a whole new level of engagement with the Copilot Studio…

Celebrating the May Super User of the…

LaurensM is an exceptional contributor to the Power Platform Community…

Check out the Copilot Studio Cookbook…

We are excited to announce our new Copilot Cookbook Gallery in the Community…

Leaderboard

#1
renatoromao Profile Picture

renatoromao 6,459

#2
Pstork1 Profile Picture

Pstork1 1,997

#3
Expiscornovus Profile Picture

Expiscornovus 1,708

Leaderboard

Featured topics