Announcements
In Copilot studio, I was able to follow the steps to create a copilot that is connected to a SharePoint site as a source.https://www.youtube.com/watch?v=2-VYwC6Akiw
With my global admin account, in the SharePoint site, I can query the content of the site. However when I connect with another regular user account (read or write on the site), it gets the error 'AccessToBotDenied' after entering the code.
For all users to use a bot (Copilot), do we need to give them specific permissions, licences?
Yes, permissions are necessary. See here: Share and collaborate on copilots with other users (contains video) - Microsoft Copilot Studio | Microsoft Learn
I'm sharing the updated steps to follow how to create a chatbot on a SharePoint page.
Copilot Bot for SharePoint | KTNN SharePoint (wordpress.com)
Hi @adilei !
Does the App registration also need to be setup when we embed our copilot studio in Canvas App via the "Chatbot" control ?
"The definitive solution involved granting permissions in Copilot Studio. Under the Security menu, not only follow video instructions granting permissions at authentication option, also select 'Share' and grant permissions to all tenant members."
It was correctly shared, the issue was comming from the "Chatbot" Control in Canvas App. It takes an hardcoded params "Environment ID". The bot displayed in the UAT app was the DEV bot and for obvious reasons the DEV one was not shared with the users.
Under review
Thank you for your reply! To ensure a great experience for everyone, your content is awaiting approval by our Community Managers. Please check back later.
Congratulations to our community stars!
Expanding mentorship, skilling, and AI innovation
These are the community rock stars!
Stay up to date on forum activity by subscribing.
Mohsin Ali 386
Valantis 263 Super User 2026 Season 2
11manish 214 Super User 2026 Season 2