Skip to main content

Notifications

Publish & Channel Management
Unanswered

Non-existing errors when publishing Chatbot

Posted on by 4

Hello everyone.

 

I wanted to publish the latest changes of my Chatbot, but when I click on publish, there is an error message, saying that I have some topics with errors, and I need to fix these errors to publish the latest content.

 

Noedlhm_0-1710511575329.png

But when I go to the Topic session, I see that there aren't any errors in my topics.

 

Noedlhm_1-1710511639919.png

Is anyone can help me with this problem ? I'm pretty stuck at the moment..

 

Thank you in advance !

 

Noé

 

Categories:
  • Re: Non-existing errors when publishing Chatbot

    Many tx @remidyon is now fine on genAI settings.

    But i've got this new error : "

    Spoiler (Highlight to read)
    One or more plug-ins are active within your copilot, this feature requires administrator approval for publication. Deactivate your plug-ins or contact your administrator to publish this copilot
    One or more plug-ins are active within your copilot, this feature requires administrator approval for publication. Deactivate your plug-ins or contact your administrator to publish this copilot

    .I exported as a solution, went through all config files but don't seen any plugin. How should identify the related plugin

    BR 

    Gillou

  • remidyon Profile Picture
    remidyon on at
    Re: Non-existing errors when publishing Chatbot

    @Gillou 

    Go to settings, generative AI, change the value to "generative", save: that will add the "internal knowledge" toggle in the overview. Then you can change the setting back to "classic"

     

    remidyon_0-1716989260871.png

     

  • Re: Non-existing errors when publishing Chatbot

    many thanks @remidyon  for your support. It's working for new created bot...I can publish. But My bot that was created before the release of new version of copilot I don't have the option to disable. As you can see in the screenshot below.

    COuld I export my Bot And Import in the new version?

    Gillou_0-1716983726415.png

     

  • remidyon Profile Picture
    remidyon on at
    Re: Non-existing errors when publishing Chatbot

    Hello @Gillou -

    When you use the conversation window to create a new copilot by describing its personality, style, use, etc it automatically activates the internal model Knowledge (as you can see in the bot configuration). You need to skip the conversational assistant during creation by not inputing any data and just press create. To change this for already existing bot you need to turn off "use own general knowledge" in the bot overview

     

    remidyon_0-1716981892441.png

     

  • Re: Non-existing errors when publishing Chatbot

    Hello  We tried to set up DLP policies as recommanded but it still not working.
    We think that the issue is that while creating a default bot even deactiving "Converstional boosting" topics that use Gen AI features, it expect GPT settings to be activated.

    In our organization GPT is not allowed for all powerplatform products.

    Here is defautl the bot settings when creating from scratch :

    [11:51] NOUTCHA Gilles

    "$kind": "BotConfiguration",   "gPTSettings": {     "$kind": "GPTSettings",     "defaultSchemaName": "crd66_copiloteTest2.gpt.default"   },   "aISettings": {     "$kind": "AISettings",     "useModelKnowledge": true   }

    @remidyon

  • Re: Non-existing errors when publishing Chatbot

    Hello @remidyon 

    Which DLP policies were rolled out last week? Could you please elaborate?

    Regarding the genAI features, it's not allowed within our organization and within the bot I don't use genAI feature and also deactivate the only topic that was using the genAI (Conversationnal Boosting).

    Thank you in advance for your support.

     

  • remidyon Profile Picture
    remidyon on at
    Re: Non-existing errors when publishing Chatbot

    @Gillou 

    Check out the new DLP policies that were rolled out last week, they control the genAI features - that explains the error you see in your logs

  • Noedlhm Profile Picture
    Noedlhm 4 on at
    Re: Non-existing errors when publishing Chatbot

    Hello @Gillou .

    Unfortunately I had to start another Copilot from scratch..

     

    I didn't manage to fix my Topics.

    I hope your problem will find a solution

     

    Best,

    Noé

  • Re: Non-existing errors when publishing Chatbot

    Hello I'm facing the same issue.

    Went through Dataverse entries related to my bot this is what I've seen.

    For your information the used of GenAI features is banned in our organization and I'm facing this error since the update of Copilot Authoring environment.

    Could you please @remidyon help us to fix it? 

    @Noedlhm Did you fix your issue?

  • remidyon Profile Picture
    remidyon on at
    Re: Non-existing errors when publishing Chatbot

    Hi @Noedlhm 

    Did you check your plugin action and system topics?

    Sometimes errors do not show on the list but when you open a topic you will see them

Helpful resources

Quick Links

Exciting News for Copilot Studio Communi…

Get ready to experience a whole new level of engagement with the Copilot Studio…

Celebrating the May Super User of the…

LaurensM is an exceptional contributor to the Power Platform Community…

Check out the Copilot Studio Cookbook…

We are excited to announce our new Copilot Cookbook Gallery in the Community…

Leaderboard

#1
renatoromao Profile Picture

renatoromao 6,459

#2
Pstork1 Profile Picture

Pstork1 1,990

#3
Expiscornovus Profile Picture

Expiscornovus 1,700

Featured topics