web
You’re offline. This is a read only version of the page.
close
Skip to main content

Announcements

News and Announcements icon
Community site session details

Community site session details

Session Id :
Power Automate
Unanswered

maximum field length

(0) ShareShare
ReportReport
Posted on by 2

I have a flow that has "failed"  The error message says this: 

 

OpenApiOperationParameterValidationFailed. The 'inputs.parameters' of workflow operation 'Create_item' of type 'OpenApiConnection' is not valid. Error details: The API operation 'PostItem' requires the property 'item/relatedexperience' to be a string of maximum length '255' but is of length '267'.

 

I can see the submission that a participant has made.  I was thinking I could either just delete a few of the words to make the submission shorter, or make the field length longer.  But I can't figure out how to do either of those.  Could anyone help me?  Thanks! 

 

 

 

Categories:
  • yashag2255 Profile Picture
    24,769 Super User 2024 Season 1 on at

    Hey @kmaclean 

     

    Can you share more details on the scenario that you are trying to build? Maybe a screenshot of the flow? 

     

    Note: I can see that it is a sharepoint create item action where you are trying to populate a Single Line of Text/ URL type of field and these currently limit the number of characters to 255. 

     

    In such a case, you can probably use the substring(sourcestring, 0, 255) to get the first 255 characters of the string and use that to reference the field. 

     

    Hope this Helps!

    If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

  • kmaclean Profile Picture
    2 on at

    Thank you for the response.  I am not sure how to do this though!  Where would I type this in?  Thank you! 

     

    "In such a case, you can probably use the substring(sourcestring, 0, 255) to get the first 255 characters of the string and use that to reference the field."

  • yashag2255 Profile Picture
    24,769 Super User 2024 Season 1 on at

    Hey @kmaclean 

     

    You can refer to the below sample: 

     

    dde2.PNG

    Expression: 

    if(lessOrEquals(length(variables('dd')),255),variables('dd'),substring(variables('dd'),0,255))
     
    This checks the length of the variable dd and if less than or equal to 255, use as is or else create a sub string with first 255 chars. 

     

    Hope this Helps!

     

    If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

     

  • PCKeith Profile Picture
    6 on at

    My solution was to just change the columns in my SharePoint list from "Single line of text" to "Multiple lines of text".  My flow started working perfectly even with very long answers

  • yabela Profile Picture
    53 on at

    Hello, what if I do not want to create a substring of the original string and I want to keep all of it? In my case, I have a field called FileURL and I was getting an error that I was trying to input 130 characters while the field had a max. character size of 100. I went to my table, changed the maximum size of the field to 500, published the changes, and tried to run the flow again but it still fails with the same error. 

     

    Any ideas on how I can fix this, please? 

  • ChuckN Profile Picture
    5 on at

    The same issue. The SP field is already multiple line type and target table column is varchar(max) and still getting the error.  

    MS need to fix this.

  • Community Power Platform Member Profile Picture
    Microsoft Employee on at

    This did the trick for me, too!

  • Community Power Platform Member Profile Picture
    Microsoft Employee on at

    Have you re-tried? for me it did the trick, but not immediately, apparently it takes some action (hard refresh?) or time lapse to update the schema before the connector realizes it can now write more than 255 chars in that column.

  • Community Power Platform Member Profile Picture
    Microsoft Employee on at

    Good point @Anonymous, many times you have made several changes to a flow or list and have no way of knowing whether or not you have solved the problem because testing it still shows an error. But waiting often resolves the problem. This is far from ideal in a production setting because it makes it extremely difficult to troubleshoot issues. Just had the same happen to me.  

  • victoraguiar Profile Picture
    43 on at

    Hello there. I have the same issue but I am importing the data from Smartsheet, did a ParseJson and want to upload a field in SQL Database. The field was originally varchar(255) and I changed to varchar(MAX). Nevertheless, it still fails. Thank you!

Under review

Thank you for your reply! To ensure a great experience for everyone, your content is awaiting approval by our Community Managers. Please check back later.

Helpful resources

Quick Links

Season of Sharing Community Challenge Winners!

Congratulations to our community stars!

Kudos to our 2025 Community Spotlight Honorees

Expanding mentorship, skilling, and AI innovation

Leaderboard > Power Automate

#1
11manish Profile Picture

11manish 231 Super User 2026 Season 2

#2
David_MA Profile Picture

David_MA 217 Super User 2026 Season 2

#3
Mohsin Ali Profile Picture

Mohsin Ali 170

Last 30 days Overall leaderboard