Skip to main content

Notifications

Power Platform Community / Forums / General / My Teams bot is broken
General
Answered

My Teams bot is broken

Posted on by 4

I published my PVA to MS Teams a while ago as a bot. It worked perfectly.

A few days ago it stopped working.

It works perfectly from a web test page and from the 'Test your bot' option, but it does not work from MS Teams. 

It is as if it wouldn't recognise phrases that are used in the bot for branching.

It's response for any phrase is: 

Sorry, I am not able to find a related topic. Can you rephrase and try again?
 
As mentioned, the test app works just fine, it only happens from MS Teams.
  • Jaschivs Profile Picture
    Jaschivs 2 on at
    Re: My Teams bot is broken

    I am having the same issue. MS Teams BOT used to work perfectly, and now it tells me "This App Cannot Be Found."

    I used to send it to be able to "chat" with the bot in Teams, but the message on the chat says "You cannot send messages to this chat."

    Any suggestions on how to make it work again would be appreciated.

  • Verified answer
    chass Profile Picture
    chass on at
    Re: My Teams bot is broken

    Please create a support ticket so we can get an engineer to investigate. 

    this can be done here: 

    https://powervirtualagents.microsoft.com/en-us/support/

     

    Thank you!

     

  • centrical Profile Picture
    centrical 4 on at
    Re: My Teams bot is broken

    I have determined that what stopped appearing is the Azure AD login card.

    Nothing changed in configuration, the bot just hangs when it should display an Authorization step.

    token.botframework.com domain is specified in valid domain list.

     

  • renatoromao Profile Picture
    renatoromao 6,459 on at
    Re: My Teams bot is broken

    @centrical ,

     

    I suggested to you to create a new bot inside the MS Teams with a simple configuration because I have the new version of MS Teams and all chatbots that I used it's working normally. Maybe your issue is related to your internal relationship inside MS Teams with PVA.

     

    I have a video to help you to publish step-by-step the chatbot inside MS Teams (if you want)

    https://www.youtube.com/watch?v=dCTxbAjOaMQ&list=PLWGKTxKF5vWc9YwqLkZB34oqJ1FGxrlSk&index=13

  • centrical Profile Picture
    centrical 4 on at
    Re: My Teams bot is broken

    I tried to re-publish. It didn't help. I also modified some text, I can see the text modification but the problem remains.

    I didn't try to create a new identical bot, it is allot of work.

    Like I said, the bot runs perfectly in test mode and embedded in a web site, just not in Microsoft Teams.

    Teams has a big version update last week - I suspect it is related.

  • renatoromao Profile Picture
    renatoromao 6,459 on at
    Re: My Teams bot is broken

    Hi @centrical ,

     

    Can you try to publish again your chatbot using the PVA Portal >> Publish menu >> Publish button? 

    Wait for 15 minutes and if your chatbot doesn't work again, try the next option below.

     

    Can you try to implement it again like a new bot? (don't delete the last bot implemented)

Helpful resources

Quick Links

Exciting News for Copilot Studio Communi…

Get ready to experience a whole new level of engagement with the Copilot Studio…

Celebrating the May Super User of the…

LaurensM is an exceptional contributor to the Power Platform Community…

Check out the Copilot Studio Cookbook…

We are excited to announce our new Copilot Cookbook Gallery in the Community…

Leaderboard

#1
renatoromao Profile Picture

renatoromao 6,459

#2
Pstork1 Profile Picture

Pstork1 1,990

#3
Expiscornovus Profile Picture

Expiscornovus 1,700

Leaderboard