Skip to main content

Notifications

Copilot Studio - General
Unanswered

Bot id not found error when using ContentConverter utility

Posted on by

I am following this documentation to convert my PVA bot content into .lu format using the contentconverter utility but on running this utility it throws "bot id not found" error even though I'm passing the bot id as a parameter. 

 

On checking the 2 CSV files which are also being passed as a parameter, it seems like the "msdynce_botcontents.csv" file just contains the column headers and no records. Does this mean that exporting the bot content through power apps was unsuccessful and if so how to resolve it?

 

Error message

msdynce_botcontents.csv file content

Categories:
  • Lokesh3 Profile Picture
    Lokesh3 4 on at
    Re: Bot id not found error when using ContentConverter utility

    @Jcook if you have got any solution then please help me with this issue.

  • Lokesh3 Profile Picture
    Lokesh3 4 on at
    Re: Bot id not found error when using ContentConverter utility

    hi @hagang,

    I am facing same issue while exporting files from PVA.

    did you get any solution for this?

    Please help me with the solution if any.

     

    Thanks.

     

  • Jcook Profile Picture
    Jcook 7,765 on at
    Re: Bot id not found error when using ContentConverter utility

    @renatoromao, Could you look at this and close please 😄

  • Jcook Profile Picture
    Jcook 7,765 on at
    Re: Bot id not found error when using ContentConverter utility

    Hello @hagang 

     

    Are you still having trouble with this?

    Please let us know.

     

    Thanks

     

  • Jcook Profile Picture
    Jcook 7,765 on at
    Re: Bot id not found error when using ContentConverter utility

    Hi @hagang 

     

    I have searched around and tried. But I have been unsuccessful ☹️.

     

    Consider adding this feature to the ideas section here:

    https://aka.ms/pva/community/ideas

     

    A support ticket with the PVA team may also be useful, since the Documentation is still referencing this tool, which seems to have been broken for awhile now

    Support | Microsoft Power Virtual Agents

  • hagang Profile Picture
    hagang on at
    Re: Bot id not found error when using ContentConverter utility

    Hi @Jcook,

     

    Thanks for your response!

    Is there any alternate way to convert the bot content to json format to use it with the dispatch tool? 

  • Jcook Profile Picture
    Jcook 7,765 on at
    Re: Bot id not found error when using ContentConverter utility

    Hi @hagang 

     

    This looks like a known bug ☹️.

    https://github.com/microsoft/dynamics365-virtualagent-samples/issues/3

     

    New updates to the compose could have broken it.

Helpful resources

Quick Links

Welcome to the Power Platform…

We are thrilled to unveil the newly-launched Power Platform Communities!…

Getting Started…

Welcome to the Power Platform Community! We appreciate your visit…

Welcome to the new Power Platform Community!…

We are excited to announce our new Copilot Cookbook Gallery in the Community…

Leaderboard

#1
WarrenBelz Profile Picture

WarrenBelz 138,030

#2
RandyHayes Profile Picture

RandyHayes 76,308

#3
Pstork1 Profile Picture

Pstork1 63,085

Leaderboard