Hi all,
We have a PowerApp (Flow/Sharepoint/SQL) running for over 2 months, no problems, but today, for no reason, a Flow is triggered from the PowerApp, the following message is displayed:
The service returned an error: SQL-Insert!Run: This app is not authorized to access this service. Try reopening the app and ensure all connections have been resolved -
.
As SQL-Insert is the name for the Flow which is basically:
PowerApp (Trigger) -> Compose ("@formatDateTime(utcnow(), 'g')") -> SQL Insert (ComposeResult, UserName from PowerApp)
(1 trigger, 2 simple steps)
On-Prem gateway services has been restarted, all working without problems. Also, I did checked the permissions on:
Gateway
Connection/Service
PowerApp
And it is set for all corporate users to "Use" - nothing changed from the past month...
Nothing was changed, I tried recreating the Flow, reassigning its permission to the flow, and even, removing and adding all permissions to all services again... no results... any idea?