Skip to main content

Notifications

Copilot Studio - General
Unanswered

SSO in PVA

Posted on by 1

Hi all,

Has any one tried configuring SSO in PVA.

I am trying do the same but facing some issues.
After completing the configuration as per - https://docs.microsoft.com/en-us/power-virtual-agents/configure-sso.

 

i am getting error as- AADSTS50011: The reply URL specified in the request does not match the reply URLs configured for the application:<GUID>.

 can any on help me in the same.

  • pawan-msft Profile Picture
    pawan-msft on at
    Re: SSO in PVA

    @Amol_Kavnekar / @RezaDorrani - There's a bug in our documentation where the screenshot to illustrate entering the redirect URL is showing 'https://token.botframework.com..' endpoint when it should really be 'https://<your web page's URL>'. That seems to be the cause of confusion here. We will be fixing the documentation soon.

     

    Thank you!

  • pawan-msft Profile Picture
    pawan-msft on at
    Re: SSO in PVA

    This is usually a sign that you canvas application's reply URL (== redirect URI) is not configured to be the URL where your chat canvas is hosted. Here's the instruction,

     

    >> Under Redirect URIs add the full URL to the page where your chat canvas is hosted. Under the Implicit grant section, select the Id Tokens and Access Tokens checkboxes.

     

    Hope that works.

     

    -Pawan

Helpful resources

Quick Links

Exciting News for Copilot Studio Communi…

Get ready to experience a whole new level of engagement with the Copilot Studio…

Celebrating the May Super User of the…

LaurensM is an exceptional contributor to the Power Platform Community…

Check out the Copilot Studio Cookbook…

We are excited to announce our new Copilot Cookbook Gallery in the Community…

Leaderboard

#1
renatoromao Profile Picture

renatoromao 6,459

#2
Pstork1 Profile Picture

Pstork1 1,997

#3
Expiscornovus Profile Picture

Expiscornovus 1,708

Leaderboard