web
You’re offline. This is a read only version of the page.
close
Skip to main content

Announcements

News and Announcements icon
Community site session details

Community site session details

Session Id :
Power Apps
Unanswered

Powerapps Flows

(0) ShareShare
ReportReport
Posted on by Microsoft Employee

How do I fix the below error

 

{
"error": {
"code": 502,
"message": "Unable to connect to the remote server",
"source": "flow-apim-europe-001-northeurope-01.azure-apim.net",
"path": "forward-request",
"clientRequestId": "3b3e6738-2575-4406-ae79-ed7bb61f68da"
}
Categories:
  • yashag2255 Profile Picture
    24,769 Super User 2024 Season 1 on at

    Hey @Anonymous 

     

    Can you share more details about the configuration where you are seeing this error? Maybe through some logical explanation and screenshots.
     
    Hope this Helps!
     
    If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!
  • Community Power Platform Member Profile Picture
    Microsoft Employee on at

    First ScreenshotFirst ScreenshotSecondSecond

  • Community Power Platform Member Profile Picture
    Microsoft Employee on at

    See screenshots..

     

    I am a novice with scripting/coding/configs... 

     

    what I did was to add a new field to the form, which went well...now when I test I get that error...

  • yashag2255 Profile Picture
    24,769 Super User 2024 Season 1 on at

    Hi @Anonymous 

     

    A few issues have been observed when creating automated flows. So a few suggestions here: 

    1. Check and try recreating the connection to sharepoint. 

    2. If the flow was created as a template or a copy, try deleting the trigger and adding it again. 

    3. IN the flow details page check if you can see teh error "fix the flow trigger"

     

    Hope this Helps!

    If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

  • Community Power Platform Member Profile Picture
    Microsoft Employee on at

    I have clicked on Fix Flow Error , and the screenshots I sent you appear giving me the error details

  • yashag2255 Profile Picture
    24,769 Super User 2024 Season 1 on at

    Hey @Anonymous 

     

    Were you able to try 1 and 2 from my previous reponse?

     

    Hope this Helps!

     

    If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

  • Community Power Platform Member Profile Picture
    Microsoft Employee on at

    I have the same issue in Microsoft Flow, where the trigger is on a created/changed item in SharePoint list.

    Friday I exported and imported 7 flows, which all had this issue and today I have 2/7 with BadGateway and 2/7 with BadRequest. So a total of 4 out of 7 flows are down without notice.

     

    Here is information on the 2 BadGateway:

    Access-Control-Allow-Methods GET, PUT, PATCH, DELETE, POST

    Access-Control-Allow-Origin *

    Access-Control-Max-Age 3600

    Access-Control-Expose-Headers *

    Date Sat, 26 Oct 2019 20:55:45 GMT

    Content-Length 263

    Content-Type application/json

     

    {

      "error": {

        "code": 502,

        "message": "Unable to connect to the remote server",

        "source": "flow-apim-europe-001-northeurope-01.azure-apim.net",

        "path": "forward-request",

        "clientRequestId": "23adb163-ce0b-4e14-a30b-5971c3e7736c"

      }

    }

     

    Access-Control-Allow-Methods GET, PUT, PATCH, DELETE, POST

    Access-Control-Allow-Origin *

    Access-Control-Max-Age 3600

    Access-Control-Expose-Headers *

    Date Sun, 27 Oct 2019 20:34:06 GMT

    Content-Length 263

    Content-Type application/json

    {

      "error": {

        "code": 502,

        "message": "Unable to connect to the remote server",

        "source": "flow-apim-europe-001-northeurope-01.azure-apim.net",

        "path": "forward-request",

        "clientRequestId": "17bf5810-551b-48a0-8214-dbed59b611c4"

      }

    }

  • Community Power Platform Member Profile Picture
    Microsoft Employee on at

    The error is most likely that the Microsoft Flow HTTP element does periodic checks of the url and when the url is not reachable just one time (because Microsofts own server is down) then it caused this error, which stops the whole flow. Instead of just try again later and if it still does not work, send the owners an email

    I have experienced this error type for around 3-4 weeks and it is clearly a mistake on Microsoft' part and I would want them to fix it asap

Under review

Thank you for your reply! To ensure a great experience for everyone, your content is awaiting approval by our Community Managers. Please check back later.

Helpful resources

Quick Links

Season of Sharing Community Challenge Winners!

Congratulations to our community stars!

Kudos to our 2025 Community Spotlight Honorees

Expanding mentorship, skilling, and AI innovation

Leaderboard > Power Apps

#1
11manish Profile Picture

11manish 432 Super User 2026 Season 2

#2
Mohsin Ali Profile Picture

Mohsin Ali 347

#3
WarrenBelz Profile Picture

WarrenBelz 254 Most Valuable Professional

Last 30 days Overall leaderboard