I have the same issue in Microsoft Flow, where the trigger is on a created/changed item in SharePoint list.
Friday I exported and imported 7 flows, which all had this issue and today I have 2/7 with BadGateway and 2/7 with BadRequest. So a total of 4 out of 7 flows are down without notice.
Here is information on the 2 BadGateway:
Access-Control-Allow-Methods GET, PUT, PATCH, DELETE, POST
Access-Control-Allow-Origin *
Access-Control-Max-Age 3600
Access-Control-Expose-Headers *
Date Sat, 26 Oct 2019 20:55:45 GMT
Content-Length 263
Content-Type application/json
{
"error": {
"code": 502,
"message": "Unable to connect to the remote server",
"source": "flow-apim-europe-001-northeurope-01.azure-apim.net",
"path": "forward-request",
"clientRequestId": "23adb163-ce0b-4e14-a30b-5971c3e7736c"
}
}
Access-Control-Allow-Methods GET, PUT, PATCH, DELETE, POST
Access-Control-Allow-Origin *
Access-Control-Max-Age 3600
Access-Control-Expose-Headers *
Date Sun, 27 Oct 2019 20:34:06 GMT
Content-Length 263
Content-Type application/json
{
"error": {
"code": 502,
"message": "Unable to connect to the remote server",
"source": "flow-apim-europe-001-northeurope-01.azure-apim.net",
"path": "forward-request",
"clientRequestId": "17bf5810-551b-48a0-8214-dbed59b611c4"
}
}