web
You’re offline. This is a read only version of the page.
close
Skip to main content

Announcements

News and Announcements icon
Community site session details

Community site session details

Session Id :
Power Platform Community / Forums / Power Automate / File System Credential...
Power Automate
Unanswered

File System Credentials Errors

(0) ShareShare
ReportReport
Posted on by 7

I successfully added a File System connection for my local C: drive. However, I have a NAS which is mapped to N:. I've been trying unsuccessfully for a few days to get it to work. It is going through the same gateway. I've tried various versions of domain\username. I've tried both N: and \\My-NAS and nothing seems to work. Here are the error codes that I'm getting depending on the formatting of my domain\username.

 

Error code: '403', Message: 'The credentials for this connection do not have access to '', please try using a different location or account. clientRequestId: 5A2ADDE9-7AF3-4025-A206-F5B6BE5B2E9B'. More diagnostic information: x-ms-client-request-id is '5A2ADDE9-7AF3-4025-A206-F5B6BE5B2E9B'.

 

dyfink_0-1668735514616.png

 

(I think this is the one when the domain\username is incorrect.

Error code: '400', Message: 'The requested action could not be completed. Check your request parameters to make sure the path '' exists on your file system. clientRequestId: 7ABEBEEA-A547-4284-9502-FE34E2FE4105'. More diagnostic information: x-ms-client-request-id is '7ABEBEEA-A547-4284-9502-FE34E2FE4105'.)

 

Thanks in advance for any help.

Categories:
  • CFernandes Profile Picture
    8,504 Most Valuable Professional on at

    Hey @dyfink 

     

    The error told that the credentials for the connection do not have access to your folder.

     

    Can you please review the thread - https://powerusers.microsoft.com/t5/Using-Connectors/Problem-connecting-to-File-System-in-Flow/td-p/84581

     

    If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

     

    P.S. take a look at my blog here and like & subscribe to my YouTube Channel thanks.

  • dyfink Profile Picture
    7 on at

    I finally found a solution to my issue here: https://powerusers.microsoft.com/t5/Using-Connectors/Problem-connecting-to-File-System-in-Flow/m-p/136718/highlight/true#M3193

     

    1. I created a user on my on-premises gateway host computer with the same user name & password as my Synology NAS user account.
      • It is just a Standard account and doesn't have anything shared with it.
    2. User those credentials for the File System Connection
      • MY-PC\Mr My Name (like DOMAIN\username, but use the new account that you just created on your local computer)
      • dyfink_0-1684883815215.png

    The only thing you really need to keep in mind is that when you change your NAS password, you will need to change it both on the local account and on the File System connection in your Power Automate console.

     

    After that it worked like a charm. I hope this helps someone else (or me next time it breaks).

Under review

Thank you for your reply! To ensure a great experience for everyone, your content is awaiting approval by our Community Managers. Please check back later.

Helpful resources

Quick Links

Season of Sharing Community Challenge Winners!

Congratulations to our community stars!

Kudos to our 2025 Community Spotlight Honorees

Expanding mentorship, skilling, and AI innovation

Leaderboard > Power Automate

#1
11manish Profile Picture

11manish 237 Super User 2026 Season 2

#2
David_MA Profile Picture

David_MA 227 Super User 2026 Season 2

#3
Mohsin Ali Profile Picture

Mohsin Ali 194

Last 30 days Overall leaderboard